Mailinglist Archive: opensuse-packaging (76 mails)

< Previous Next >
Re: [opensuse-packaging] Disabling systemd services in %post for upgrades
Hi,

On Thu, 10 May 2018, John Paul Adrian Glaubitz wrote:

SLE11SP4 has no relation to suse_version 1140. SLE11SP4 is
suse_version == 1110

Seems very inconsistent and confusing to me.

It's not anymore when you know how it came to be, so:
* SLE codestreams use the same suse_version for all service packs
* hence, SLE11 suse_version is the earliest for that code stream
* SLE11 was split off openSUSE 11.1 (which had suse_version 1110)
* So SLE11 suse_version is same (to differentiate there's %sles_version)
* for SLE12 the convention was adjusted to also tick up suse_version after
split-off (from oS 13.1; suse_version 1310 to 1315)
* for SLE15 there was an failed attempt to get rid of %suse_version,
plus the fact that openSUSE became rolling, which
in the end resulted in some inconsistencies to before, e.g. %sle_version
(not %sles_version anymore), and %suse_version 1500
* the above SLE11 convention also held for SLES7, SLES8, SLE9 and SLE10


Ciao,
Michael.
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >