Mailinglist Archive: opensuse-packaging (116 mails)

< Previous Next >
[opensuse-packaging] Build package for TW (>=20171129) with a need of postgresql-devel
I'm stuck actually to resolve the case I need to build a package for actual TW

In spec I have

112 Requires: postgresql >= 9.1
113 Requires: postgresql-devel >= 9.1


In build log I have

[ 22s] postgresql-10-1.2
[ 23s] postgresql10-10.1-1.2
[ 23s] postgresql96-devel-9.6.5-1.1

Of course then pg_config isn't found later.

I've tried to adapt the project conf by adding the new 1550 TW version,
but still fail.

%if 0%{?suse_version} >= 1550 && 0%{?is_opensuse} == 1
Prefer: postgresql10-devel
%endif
%if 0%{?suse_version} >= 1325 && 0%{?suse_version} < 1550 && 0%{?is_opensuse}
== 1
Prefer: postgresql96-devel
%endif

Any review or help is welcome.

Could it be a bug, that now on TW if I request to install postgresql-devel
zypper only propose this package (with a 10.1 version) and have no dep to the
real default one postgresql10-devel ?

I didn't remember having this kind of trouble with previous upgrade.

--

Bruno Friedmann
Ioda-Net Sàrl www.ioda-net.ch
Bareos Partner, openSUSE Member, fsfe fellowship
GPG KEY : D5C9B751C4653227
irc: tigerfoot


--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages