Mailinglist Archive: opensuse-packaging (127 mails)

< Previous Next >
Re: [opensuse-packaging] New packaging guidelines for PHP7 pacakges
On Aug 31, 2017, at 2:07 PM, Johannes Weberhofer <jweberhofer@xxxxxxxxxxxxx>
wrote:

Am 30.08.17 um 22:01 schrieb Christian Boltz:
This should probably be <= 1320 (unless you want to exclude 13.2, which
sounds unlikely)
Besides that, your proposal looks good:-)

Thanks for you response!

Leap seems to be 1330 at the moment; I'll update this.

Not in 42.x. Looks like Tumbleweed is currently 1330 (according to
https://en.opensuse.org/openSUSE:Packaging_for_Leap#RPM_Distro_Version_Macros,
but footnoted as "never rely on this version, it may change").


$ rpm --eval %suse_version
1315

$ grep '^%.*_version' /usr/lib/rpm/suse_macros
%suse_version 1315
%sles_version 0
%ul_version 0
%leap_version 420300
%sle_version 120300

$ cat /etc/os-release
NAME="openSUSE Leap"
VERSION="42.3"
ID=opensuse
ID_LIKE="suse"
VERSION_ID="42.3"
PRETTY_NAME="openSUSE Leap 42.3"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:leap:42.3"
BUG_REPORT_URL="https://bugs.opensuse.org";
HOME_URL="https://www.opensuse.org/“


Thanks for your work; hope this leads to more packages making their way from
server:php:extensions to server:php:extensions:php7 (assuming that’s what we’re
supposed to use?). BTW, that repo has 3 packages named php5-* — old packages
which should be purged? There are corresponding php7-* packages.


-Andrew
< Previous Next >
List Navigation