Mailinglist Archive: opensuse-packaging (127 mails)

< Previous Next >
Re: [opensuse-packaging] New packaging guidelines for PHP7 pacakges
On Wed, 2017-08-30 at 15:22 +0200, Johannes Weberhofer wrote:
Dear all!

I will check that those macros will be included in php5 and php7
packages in the future, but until that's done the macros can must be
included in the spec files. Currently "BuildRequires: %{php_name}-
macros" is required, but this can be moved to the "%if
0%{?suse_version} < 1320" as soon as PHP7 has been updated in factory

php5 is scheduled for removal from openSUSE:Factory - so adding new
macros there seems like a waste of your time. Focus on PHP7 'only'

Cheers,
Dominique
< Previous Next >
List Navigation
Follow Ups
References