Mailinglist Archive: opensuse-packaging (102 mails)

< Previous Next >
Re: [opensuse-packaging] Requires(pre): user(wwwrun)

Hello,

On Apr 25 17:27 Johannes Weberhofer wrote (excerpt):
When I understand it right, for future builds
it is necessary to include systemusers like wwwrun
when required. This currently is supported only
on Tumbleweed and breaks building on other systems.

that is already implemented in the cups source package
in the Printing development project for the cups-libs
binary RPM:
----------------------------------------------------------
$ osc cat Printing cups cups.changes | less
...
Wed Mar 29 13:41:15 UTC 2017 - kukuk@xxxxxxxx

- Add /etc/cups to cups-libs package [bsc#1025689]

----------------------------------------------------------
$ osc cat Printing cups cups.spec | less
.
.
.
%package libs
...
%if 0%{?suse_version} >= 1330
Requires(pre): group(lp)
%endif
.
.
.
%files libs
...
%if 0%{?suse_version} >= 1330
%dir %attr(0755,root,lp) /etc/cups
%endif
----------------------------------------------------------

See also
https://bugzilla.opensuse.org/show_bug.cgi?id=1025689
because in this or that cases other packages may
also need adaptions (in case of cups the filesystem
package needed also adaptions because before /etc/cups
was in the filesystem package, now it is in cups-libs).


Kind Regards
Johannes Meixner
--
SUSE LINUX GmbH - GF: Felix Imendoerffer, Jane Smithard,
Graham Norton - HRB 21284 (AG Nuernberg)

--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
References