Mailinglist Archive: opensuse-packaging (129 mails)

< Previous Next >
Re: [opensuse-packaging] RPM require version range


On 04/01/2016 08:41, Ferdinand Thiessen wrote:
Hi,

How do I require a version range?
E.g. I need lua 5.2.x I tried:

BuildRequires: Lua(devel) >= 5.2, Lua(devel) < 5.3

But this will fail with a "Have choice" error, so rpm / buildservice
finds lua 5.1 and lua 5.2 for BuildRequire " Lua(devel) < 5.3". So it
does not combine the two statements.

Regards,

Ferdinand
Have you tried #!BuildIgnore: Lua(devel) >= 5.3
BuildRequires: Lua(devel) >= 5.2
#!BuildIgnore: Lua(devel) <= 5.1
It might work, it should give you a version range of 5.2.x

Regards
Dave P

--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
References