Mailinglist Archive: opensuse-packaging (129 mails)

< Previous Next >
Re: [opensuse-packaging] RPM require version range
  • From: Ferdinand Thiessen <f.thiessen@xxxxxx>
  • Date: Fri, 8 Jan 2016 02:28:46 +0100
  • Message-id: <568F10CE.7060209@gmx.de>
Hello,

Am 04.01.2016 um 12:18 schrieb Christian Boltz:
BuildRequires: Lua(devel) >= 5.2
BuildRequires: Lua(devel) < 5.3

This does not work, it produces: Unresolvable: Have choice for
Lua(devel) < 5.3: lua52-devel, lua51-devel

Am 04.01.2016 um 12:18 schrieb Christian Boltz:
So at least for 5.3.1, it seems "Lua(devel)" doesn't include the .1, so
you can probably just use
BuildRequires: Lua(devel) = 5.2

This works only for openSUSE Factory / Tumbleweed, but not for Leap,
13.2 ...

Am 04.01.2016 um 18:34 schrieb Greg Freemyer:
BuildRequires: Lua(devel) >= 5.2
Conflicts: Lua(devel) >= 5.3
This works like expected, thanks.

But thank you all for your answers.
Best regards,
Ferdinand Thiessen
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >