Mailinglist Archive: opensuse-packaging (106 mails)

< Previous Next >
Re: [opensuse-packaging] Leap, %bcond_with and python?
On Wed, 2 Dec 2015 06:27:51 +0300
Andrei Borzenkov <arvidjaar@xxxxxxxxx> wrote:

02.12.2015 02:56, Greg Freemyer пишет:
I decided to give Leap a try.

My main use case for production is a python app. The app is in OBS,
but not in Leap. (I may be the only user, so it is not a big loss.)

In trying to get it going I find that python-protobuf is not in
Leap either.

Now that surprises me. python-protobuf has been in openSUSE since
at least 13.1 as a sub-project of protobuf.

The Leap protobuf specfile is at:
https://build.opensuse.org/package/view_file/openSUSE:Leap:42.1/protobuf/protobuf.spec?expand=1

Looking at the specfile for protobuf it says:

%if 0%{?suse_version} > 1210 && 0%{?suse_version} != 1315
%bcond_without protobuf_python
%else
%bcond_with protobuf_python
%endif

I don't recall coming across bcond before, but that logic seems
totally backwards to me. I gather that the suse_version being 1315
in Leap causes the python binding subproject not to be built.

questions:

- if I hard code "%bcond_without protobuf_python" then the python
bindings subproject is built. In plain english, what does
%bcond_without mean?


It adds "--without protobuf_python" argument support to rpmbuild
command line. It does *not* itself affect whether it is built or not
- somewhere else SPEC must check condition (with_protobuf_python in
this case) and behave accordingly.

http://www.rpm.org/wiki/PackagerDocs/ConditionalBuilds



Greg,

I did a little digging and it seems Leap should have the python
bindings, but somehow they did not get inserted into the Leap repo. If
you look at the -devel project they are built and published.

So, to get them in the distro a maintenance SR is needed. I do not
maintain that repo, otherwise I'd fix it myself.

http://download.opensuse.org/repositories/devel:/tools:/building/openSUSE_Leap_42.1/x86_64/
has it

http://download.opensuse.org/distribution/leap/42.1/repo/oss/suse/x86_64/
does not



HTH,

Peter
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups