Mailinglist Archive: opensuse-packaging (106 mails)

< Previous Next >
Re: [opensuse-packaging] Create a rpm-spec which forces a higher version to be replaced be a lower version
Am 27.11.2015 um 11:21 schrieb Johannes Weberhofer:
Hello!

I have the following problem: A package which has been versioned without number but with
a date as version number ( mediawiki-math-1401961173 ) starting some month ago, the
package has now a "real" version number (1.26). I'd like to use the new number,
but I do not see how I could force a update then...

Best regards,
Johannes

I have found a solution which works:

As mediawiki-math requires mediawiki I have updated mediawiki to have an conflict with
"mediawiki-math > 20000000". Therefore zypper asks automatically for
downgrading.

Best regrads,
Johannes

--
Johannes Weberhofer
Weberhofer GmbH, Austria, Vienna
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages