Mailinglist Archive: opensuse-packaging (118 mails)

< Previous Next >
Re: [opensuse-packaging] suse_version handling troubles/solutions
  • From: Ludwig Nussel <ludwig.nussel@xxxxxxx>
  • Date: Fri, 12 Jun 2015 09:32:06 +0200
  • Message-id: <557A8AF6.9090201@suse.de>
Johannes Meixner wrote:
On Jun 11 15:55 Jan Engelhardt wrote (excerpt):
On Thursday 2015-06-11 15:52, Johannes Meixner wrote:

I would prefer if I could test for the actual requirement like
------------------------------------------------------------------
%if %build_system_package_version foo >= 1.2.3
BuildRequires: foo
%endif

But exactly that was already identified to be a problem of its own.
In one repository, you have foo>= 1.2.3, and in another you don't,
making the whole thing not as reproducible as one would want to.

Yes I know.

If I want to ensure it is compiled "--with-something"
for openSUSE >= 13.2 I would specify that as my actual condition
if the plain version value is actually the real requirement
(but see what I wrote at the end):
-------------------------------------------------------------------------
# Since openSUSE 13.2 compile it "--with-something":
%if 0%{?suse_version} >= 1320
BuildRequires: something
%endif
.
.
.
# Since openSUSE 13.2 compile it "--with-something":
%configure \
%if 0%{?suse_version} >= 1320
--with-something \
%endif

%if 0%{?suse_version} >= 1320
%bcond_without something
%else
%bcond_with something
%endif
...
%configure \
%{?with_something:--with-something}

cu
Ludwig

--
(o_ Ludwig Nussel
//\
V_/_ http://www.suse.de/
SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard,
Dilip Upmanyu, Graham Norton, HRB 21284 (AG Nürnberg)
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >