Mailinglist Archive: opensuse-packaging (118 mails)

< Previous Next >
Re: [opensuse-packaging] suse_version handling troubles/solutions
On Thu, Jun 11, 2015 at 01:23:06PM +0200, Tomáš Chvátal wrote:
Redo how we think about optional features and why we use the suse_version.

Instead of
%if suse_version > 1140
BuildRequires: bla
%endif
We could devise in rpm like TryBuildRequires which would pull in packages if
they are around and otherwise provide some packagename = 0 for further
depending conditions.

I like this idea. I don't like the name - to use a keyword containing
"Requires" for something that is not required would be confusing.
Perhaps BuildRecommend?

We might want to go a step further. Many of my suse_version tests are
to handle packages named differently in different versions. What I would
appreciate would be syntax like e.g.

BuildRequires: (name1 name2 name3)

which would take first name available. (The new keyword should also
support this syntax.)

Michal Kubeček

--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
References