Mailinglist Archive: opensuse-packaging (118 mails)

< Previous Next >
Re: [opensuse-packaging] suse_version handling troubles/solutions

On Thursday 2015-06-11 15:52, Johannes Meixner wrote:

I would prefer if I could test for the actual requirement like
------------------------------------------------------------------
%if %build_system_package_version foo >= 1.2.3
BuildRequires: foo
%endif

But exactly that was already identified to be a problem of its own.
In one repository, you have foo>= 1.2.3, and in another you don't,
making the whole thing not as reproducible as one would want to.
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups