Mailinglist Archive: opensuse-packaging (118 mails)

< Previous Next >
Re: [opensuse-packaging] suse_version handling troubles/solutions

Hello,

On Jun 11 13:46 Olaf Hering wrote (excerpt):
Given the roadmaps I have seen suse_version can cope
with the roadmap:
1315 = GA
1316 = SP1+
etc.

Some time ago I was (somewhat imperiously) told that
distinguishing between SLE service packs is wrong.

If I remember correctly the reason behind is that
a package e.g. for SLE11 must be installable in
SLE11-GA and in any SLE11 service pack.

This is confirmed in https://en.opensuse.org/openSUSE:Build_Service_cross_distribution_howto
--------------------------------------------------------
ServicePacks cannot be distinguished.
SLES11 SP1 sets exactly the same variables as SLES11.
--------------------------------------------------------

Accordingly there will not be 1316 for SLE12-SP1.
SLE12-GA and all SLE12 service packs will have 1315.


Kind Regards
Johannes Meixner
--
SUSE LINUX GmbH - GF: Felix Imendoerffer, Jane Smithard,
Dilip Upmanyu, Graham Norton - HRB 21284 (AG Nuernberg)

--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >