Mailinglist Archive: opensuse-packaging (129 mails)

< Previous Next >
[opensuse-packaging] Use of generics in "requires" statements?
All,

My SR to add a couple of generic "Requires:" to the wordpress spec
file has been rejected because they are generic:

https://build.opensuse.org/request/show/304469

My re-opened SR was also rejected.

Can someone explain to my why the use of

Requires: httpd
Requires: mod_php_any

is wrong. I know the below will also work, but I don't see why we
should be restrictive

Requires: apache2
Requires: apache2-mod_php5

That is unless wordpress is strictly a apache2 based tool, but I can't
imagine that is true.

fyi: In the SR Eric did say:

"httpd only for other than opensuse."

I don't understand that since apache2, lighttpd and nginx all provide
httpd in their opebnsuse packages.

He also said
"zypper se php_mod_any" show "package not found"

That is true, but "zypper se" doesn't search for generic provides so
that logic would invalidate all use of generic requires.

Thanks
Greg
--
Greg Freemyer
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups