Mailinglist Archive: opensuse-packaging (129 mails)

< Previous Next >
[opensuse-packaging] Update to Clang 3.6 pulls in hundreds of package changes
  • From: Christoph GrĂ¼ninger <foss@xxxxxxxxxxxxx>
  • Date: Wed, 15 Apr 2015 09:18:39 +0200 (CEST)
  • Message-id: <1660567110.2135440.1429082319426.JavaMail.open-xchange@ptangptang.store>
Hi packagers,
I wanted to update Clang 3.5 to 3.6 using the devel:/tools:/compiler repository.
When doing so with Yast2, it complained that several packages require
libclang-3.5
and they offered to change more then 1600 packages from 64 bit to 32 bit. That's
ridiculous.
Is there a way to keep the old libclang and install the new one, too? Why is it
not possible to have several Clang version installed? With GCC it works quite
fine
and to my knowledge GCC is by far more integrated in the whole software stack.

Bye
Christoph
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages