Mailinglist Archive: opensuse-packaging (102 mails)

< Previous Next >
Re: [opensuse-packaging] Re: Python 3 only
  • From: Tomáš Chvátal <tchvatal@xxxxxxx>
  • Date: Tue, 24 Feb 2015 14:51:17 +0100
  • Message-id: <2180841.gvamfNV4uq@bugaboo>
Dne Út 24. února 2015 14:44:00, Benjamin Denisart napsal(a):
On 02/24/2015 02:42 PM, Alberto Planas Dominguez wrote:
On Tuesday, February 24, 2015 02:19:29 PM Benjamin Denisart wrote:
If we want doing something to reduce mass of work, we should

instead

decide what to do with python2 and 3 packages. I purpose that each

time

a package is py3-compatbile and is not a dependency of a py2-only
package, we provide py3 version only in Factory.

Quite radical! : )

I kind of like the idea, but maybe makes more sense after the default
Python version installed in Factory is only Python 3. After that, we can
make Factory an only Python 3 distribution, removing packages like in
your proposal.


Thanks,
Alberto Planas

Sure, but not before a long time so ! Cause a lot of packages still
doesn't support py3. And because we don't have final specifications for
unified specfile.

For this Jan was quite busy with other tasks, so he will now start working in
this direction. (And it is the actual reason for his mail to -factory, to show
that the things start moving :))

So I would recommend first finishing up unified spec idea and then deciding how
to reduce it on Factory.

Also funny part will be to ensure the unified specs to work on SLE11 if someone
is interested, as it will probably need quite backports of macro
declarations/etc.

Cheers

Tom
< Previous Next >