Mailinglist Archive: opensuse-packaging (155 mails)

< Previous Next >
Re: [opensuse-packaging] apache2-mod_authnz_external depending on Apache version

On Wednesday 2014-01-29 09:53, vetter@xxxxxxxxxxxxxxxxxxxxxxx wrote:

this is probably answered before, but I didn't find anything in the
archives and Packaging Guidelines.
apache2-mod_authnz_external comes upstream in different versions for
different apache versions:
3.3.x is for Apache 2.3/2.4
3.2.x is for Apache 2.2

Typically, there would have to be two packages that conflict with
each other:
apache2-mod_authnz_external (for 3.3), requiring apache2-mpm >= 2.4
and nothing else

and

apache2-mod_authnz_external-3_2 (for 3.2), requiring apache2-mpm < 2.4
and conflicting with apache2-mod_authnz_external.

This is (very loosely) indicated by
http://en.opensuse.org/openSUSE:Package_naming_guidelines#Multiple_packages_for_the_same_software

I thought about including version number in the package name. That would
probably mean to also change name of the existing package?

Indeed it would. (And it's just a copy of the existing package
before you SR the new version.)

--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
References