Mailinglist Archive: opensuse-packaging (155 mails)

< Previous Next >
Re: [opensuse-packaging] Re: Help with build cycle
On 01/18/2014 10:44 AM, Guido Berhoerster wrote:
* Robert Schweikert <rjschwei@xxxxxxxx> [2014-01-18 16:31]:
On 01/18/2014 09:38 AM, Yamaban wrote:
On Sat, 18 Jan 2014 12:57, Robert Schweikert <rjschwei@...> wrote:

Hi,

Could use some help with the following problem:

Getting buildconfig from server and store to
/work/rjschwei/obs/filesystems/s3fs/.osc/_buildconfig-openSUSE_13.1-x86_64

buildinfo is broken... it says:
unresolvable: have choice for libss.so.2()(64bit) needed by krb5-mini:
libcom_err2 libcom_err2-mini, have choice for libcom_err.so.2()(64bit)
needed by krb5-mini: libcom_err2 libcom_err2-mini

This occurs for filesystems:s3fs, which I am trying to update to 1.74

Shot in the dark, the line:

BuildRequire: krb5-mini libcom_err2-mini

Thanks, that did the trick

It does but it is the wrong solution and you add an unecessary
build dependency, see my other mail.


Yes, you are correct. This just goes to show how powerful predisposition is. I was following a thread for a while that had krb5 as the main topic and how we would end up with more build cycles and how to break them. Thus, the grey matter upon recognizing krb5 came to the obvious conclusion "build cycle" after all I was reading e-mails about it a while back....

Anyway, I am not a project maintainer for filesystems thus I cannot edit the project config, but I am certain one of the nice project maintainers will do that for me.

Thanks,
Robert


--
Robert Schweikert MAY THE SOURCE BE WITH YOU
SUSE-IBM Software Integration Center LINUX
Tech Lead
Public Cloud Architect
rjschwei@xxxxxxxx
rschweik@xxxxxxxxxx
781-464-8147
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >