Mailinglist Archive: opensuse-packaging (155 mails)

< Previous Next >
[opensuse-packaging] Re: Re: Re: Help with build cycle
On Sat, 18 Jan 2014 16:44, Guido Berhoerster <gber@...> wrote:
* Robert Schweikert <rjschwei@xxxxxxxx> [2014-01-18 16:31]:
On 01/18/2014 09:38 AM, Yamaban wrote:
On Sat, 18 Jan 2014 12:57, Robert Schweikert <rjschwei@...> wrote:

Could use some help with the following problem:

Getting buildconfig from server and store to
/work/rjschwei/obs/filesystems/s3fs/.osc/_buildconfig-openSUSE_13.1-x86_64

buildinfo is broken... it says:
unresolvable: have choice for libss.so.2()(64bit) needed by krb5-mini:
libcom_err2 libcom_err2-mini, have choice for libcom_err.so.2()(64bit)
needed by krb5-mini: libcom_err2 libcom_err2-mini

This occurs for filesystems:s3fs, which I am trying to update to 1.74

Shot in the dark, the line:

BuildRequire: krb5-mini libcom_err2-mini

Thanks, that did the trick

It does but it is the wrong solution and you add an
unnecessary build dependency, see my other mail.

IMHO krb5-mini should ask for / prefer libcom_err2-mini
that way this ambiguity would never exist.

Otherwise it's better to declare the dependency in full,
and have control over it.

For me a from the start fully declared requirement is
the better way to go, that's why I proposed the above
BuildRequire - line: easy to see, easy to handle.

Wishing upon the shooting stars would be a automatic
and general "Prefer: *-mini" in the whole obs, to
limit wasting of resources within obs.

But, none the less, thanks for advising the alternative.

- Yamaban.
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >