Mailinglist Archive: opensuse-packaging (155 mails)

< Previous Next >
Re: [opensuse-packaging] Re: RPM in openSUSE 13.1
On Wednesday 15 January 2014 23.58:50 Marco Cimmino Gibellini wrote:
Hi,
unluckily Skype is a 32-bit binary only and to communicate with PulseAudio it
requires also alsa-plugins-pulse at 32-bit, the 64-bit package does not help.
This actually started since openSUSE 13.1 64-bit, that package for some
reason was not required on openSUSE 12.1 64-bit; I did not check intermediate
versions to know when exactly became necessary.

We do not use overlapping package names like Fedora. (You can't
easily run rpm -U or rpm -i,-e on them in some cases.)

In other words, our package names / with arch symbols would be:
Requires: libz1(x86-64)
Requires: libz1-32bit(x86-32)

So you are saying we can include the following in the Requires:
Requires: alsa-plugins-pulse(x86-32), alsa-plugins-pulse-32bit(x86-64)

Yours sounds odd as the '-32bit- package names are usually available on
x86-64 and not x86-32 as far as I can tell.

best
Marco--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx


Wouldn't it make sense to offer a true native 64bits of that software.

:-)


--

Bruno Friedmann
Ioda-Net Sàrl www.ioda-net.ch

openSUSE Member
GPG KEY : D5C9B751C4653227
irc: tigerfoot
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >