Mailinglist Archive: opensuse-packaging (155 mails)

< Previous Next >
[opensuse-packaging] Re: RPM in openSUSE 13.1
[forwarding to opensuse-packaging ML]

On 01/15/2014 11:50 PM, Marco Cimmino Gibellini wrote:
Hi,
my name is Marco Cimmino and I am the main UI developer for Skype for Linux.

I am writing to you to ask a question about an odd behaviour of rpm/package
manager installed on openSUSE 13.1.
Our main problem is to add a dependency in our Skype rpm package that depends
on a 32-bit libraries, regardless the
running openSUSE is either 32-bit or 64-bit.
This is easily achievable on Fedora 20 specifying in the RPM Requires field
something like this:
Requires: alsa-plugins-pulseaudio(x86-32)

As also stated in this document:
http://www.rpm.org/wiki/PackagerDocs/ArchDependencies

However the same thing does not work on openSUSE 13.1, if I do not mention
the architecture then it will pull the same
as the operating system, if I mention it then it fails to install it with
unmet dependencies error.
Since rpm version is exactly the same as Fedora 20, v4.11.1, I wonder why
this difference and if there is any workaround.

I hope you can give me more insight, thank you.

best
Marco Cimmino
-----
Linux UI team, Skype
UI developer
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups