Mailinglist Archive: opensuse-packaging (114 mails)

< Previous Next >
[opensuse-packaging] openSUSE ARMм7 BeagleBone Black experience
  • From: "Matwey V. Kornilov" <matwey.kornilov@xxxxxxxxx>
  • Date: Sun, 29 Dec 2013 12:16:06 +0400
  • Message-id: <CAJs94Ebg0Gt8DFB7RE8hg5Om9pT4QoykHKn3wnN=YPw=DryNTg@mail.gmail.com>
Hi Marcus and all,

I was trying to set this up and now I am in stuck. I have a piece of
this hardware and want to run openSUSE 13.1 on it. I've collected
needed packages (with u-boot-am335xevm 2013.04) in
home:matwey:beaglebone,. I took openSUSE:13.1:Ports/JeOS as a base.
Fortunately, there even was JeOS-beaglebone.kiwi, but it was not built
and published.

I've found two thing regarding to u-boot setup (quite strange):

1. u-boot looks for dtb in /boot/, when dtb-s are installed into
/boot/dtb (is it a bug?)

2. mmcboot command tries to boot the kernel with bootm command:
mmcboot=echo Booting from mmc ...; run mmcargs; bootm ${kloadaddr}
- ${fdtaddr}
when compressed zImage is installed and have to be booted with bootz command.

After this issues had been fixed manually from u-boot console, I was
able to boot the linux. Here is available full booting log:
http://paste.opensuse.org/18807914 Booting is stuck on root partition
waiting, easily something wrong with mmc card device driver, but I can
not figure out what exactly. dtb-file seems to be correct, u-boot
finds that it has to be am335x-boneblack.dtb

Will appreciate any help.

--
With best regards,
Matwey V. Kornilov
http://blog.matwey.name
xmpp:0x2207@xxxxxxxxx
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >