Mailinglist Archive: opensuse-packaging (114 mails)

< Previous Next >
Re: [opensuse-packaging] Using "~" in package version?
On 12/19/2013 01:20 AM, Johannes Meixner wrote:

Hello,

On Dec 19 10:53 Andrey Borzenkov wrote (excerpt):
Is using something like 2.02~beta1 acceptable? Brief check suggests
that RPM does support it and sorts this before 2.02, but may be there
are guidelines for it?
Since which openSUSE release is it supported BTW?

To be on the safe side I would not use it because it depends
on the package installation tools on the target system where
the binary RPM would be installed if 2.02~beta1 is newer than 2.02
or if 2.02~beta1 is older than 2.02, see

...

Currently I do not have openSUSE 12.x systems running so that I cannot
test the behaviour there.

The link that Jan provided stated that it is in rpm 4.10 and backported to 4.9.1 for openSUSE 12.2.
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >