Mailinglist Archive: opensuse-packaging (114 mails)

< Previous Next >
Re: [opensuse-packaging] Using "~" in package version?

Hello,

On Dec 19 10:53 Andrey Borzenkov wrote (excerpt):
Is using something like 2.02~beta1 acceptable? Brief check suggests
that RPM does support it and sorts this before 2.02, but may be there
are guidelines for it?
Since which openSUSE release is it supported BTW?

To be on the safe side I would not use it because it depends
on the package installation tools on the target system where
the binary RPM would be installed if 2.02~beta1 is newer than 2.02
or if 2.02~beta1 is older than 2.02, see
------------------------------------------------------------------------
# zypper versioncmp '2.02~beta1' '2.02'
2.02~beta1 is newer than 2.02

# cat /etc/SuSE-release
SUSE Linux Enterprise Desktop 11 (x86_64)
VERSION = 11
PATCHLEVEL = 2
------------------------------------------------------------------------
versus
------------------------------------------------------------------------
# zypper versioncmp '2.02~beta1' '2.02'
2.02~beta1 is older than 2.02

# cat /etc/os-release
NAME=openSUSE
VERSION="13.1 (Bottle)"
VERSION_ID="13.1"
PRETTY_NAME="openSUSE 13.1 (Bottle) (i586)"
...
------------------------------------------------------------------------

Currently I do not have openSUSE 12.x systems running so that I cannot
test the behaviour there.


Kind Regards
Johannes Meixner
--
SUSE LINUX Products GmbH -- Maxfeldstrasse 5 -- 90409 Nuernberg -- Germany
HRB 16746 (AG Nuernberg) GF: Jeff Hawn, Jennifer Guild, Felix Imendoerffer
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References