Mailinglist Archive: opensuse-packaging (114 mails)

< Previous Next >
Re: [opensuse-packaging] Re: krb5 dependency in Base:System
  • From: NeilBrown <neilb@xxxxxxx>
  • Date: Tue, 10 Dec 2013 13:58:15 +1100
  • Message-id: <20131210135815.5c1ca286@notabene.brown>
On Thu, 28 Nov 2013 12:11:34 +0100 Stephan Kulow <coolo@xxxxxxx> wrote:

On 28.11.2013 11:21, NeilBrown wrote:

Once again I have no idea what you mean. In what way, precisely,
are build requirements important. In what way might they go wrong?
What must we be careful to ensure?

What Richard tries to express is that with bootstrap problems you have
to always look at the whole cycle and not just at single packages.
Because if you fail to build one package with the rest, you enlarge
the cycle.

I reverted the change now as you proposed and I tried to setup a
staging project for this purpose, but I failed - will continue later

Greetings, Stephan


I don't know if what I've done will be useful, but I have:

-created an e2fsprogs-mini.spec in e2fsprogs which builds without any
dependencies on texinfo or tex.

home:neilbrown:branches:filesystems/e2fsprogs

This requires
osc linkpac filesystems e2fsprogs filesystems e2fsprogs-mini
to be useful.

-created a version of krb5 which depends on libcom_err-mini-devel
(from e2fsprogs-mini) and removes the needless dependency on doxygen

home:neilbrown:branches:networks/krb5

-created a version of libtirpc which depends on krb5-mini rather than krb5.

home:neilbrown:branches:Base:System:libtirpc


and created a submit request for each of those.
This should allow libtirpc to be included with minimal extra build
dependencies.

NeilBrown
< Previous Next >
Follow Ups