Mailinglist Archive: opensuse-packaging (174 mails)

< Previous Next >
Re: [opensuse-packaging] Re: krb5 dependency in Base:System
On 29.11.2013 09:43, Thorsten Kukuk wrote:
On Thu, Nov 28, Stephan Kulow wrote:

Would it be possible to have a simple module in pam and more advanced
functionality in a different package - it can even be required by pam
as long as this is requirement does not apply in the build service
(bootstrap). I mean - long term ;)

This will not solve your problem.

The RPC implementation in glibc is IPv4 only, means no IPv6.
And I don't think that this will ever change, two years ago they
even tried to get ride of RPC in glibc completly.

Which means, every application using RPC and IPv6 needs to be
linked against libtirpc. And I expect that this number of applications
will grow in the next years, not shrink.

So yes, you can start to touch some hundred packages to add workarounds
for the libtirpc/krb5 dependency issue, or you can try to find one
solution for libtirpc which would solve all of this other packages,
too.

Most of these applications are not in the bootstrap cycle, so I don't
care. I now submitted libtirpc using krb5 and it did not create another
cycle, but only because pam is not requiring it.

So all I care about is pam. The pam usage in the build service is
limited to one su call (for most packages) and that is not RPC, so I
don't care about RPC in the build system.

Possibly I can even have a su without pam for this purpose - now that I
think about it.

Greetings, Stephan

--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >