Mailinglist Archive: opensuse-packaging (174 mails)

< Previous Next >
Re: [opensuse-packaging] Re: krb5 dependency in Base:System
On 28.11.2013 12:01, Thorsten Kukuk wrote:
On Thu, Nov 28, NeilBrown wrote:

pam_unix*.so uses libtirpc, presumably for NIS (aka YP) lookup.
Do we support kerberos authentication for NIS lookup I wonder.

Several PAM modules uses libtirpc as fallback, but luckly for us,
it's only really needed for pam_unix.so. And this one uses it for
different tasks.

NIS doesn't use kerberos authentication, only plain RPC.

I couldn't find a place in pam_unix.so where we call RPC functions
and are able to support IPv6, so I removed now the libtrpc dependency
to pam. But this is only possible as long as no module uses RPC with
IPv6. So this is not a long term solution, only short term.

Would it be possible to have a simple module in pam and more advanced
functionality in a different package - it can even be required by pam
as long as this is requirement does not apply in the build service
(bootstrap). I mean - long term ;)

Greetings, Stephan



--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >