Mailinglist Archive: opensuse-packaging (68 mails)

< Previous Next >
Re: [opensuse-packaging] can apache HTTP Server be updated to version 2.4.4 [from v-2.4.3]
On Thursday 30 May 2013 01.25:27 Cristian Rodríguez wrote:
On 05/30/2013 01:14 AM, doiggl@xxxxxxxxxxxxxxxxxx wrote:
Hello,
Can apache HTTP Server be updated to version 2.4.4 [from v-2.4.3]
https://build.opensuse.org/package/show?package=apache2&project=openSUSE%3
AFactory

http://httpd.apache.org/download.cgi

Stable Release - Latest Version:
2.4.4 (released 2013-02-25)

http://httpd.apache.org/download.cgi#apache24

-- Thanks Glenn

Ok, I will update along with fixing issues reported in opensuse-factory
list.. ;-)

Today the updated 2.4.4 package hit the obs and download.

I'm seeing two problems (are they?)

Missing unixd module (needed to use User,Group directive) was present and
working in 2.4.3

Second (linked to Apache24 repository) apache2_modspdy has wrong deps
zypper se -s spdy
Loading repository data...
Reading installed packages...

S | Name | Type | Version | Arch | Repository
--+------------------+------------+-------------+--------+-----------
| apache2-mod_spdy | srcpackage | 0.9.1.5-1.1 | noarch | apache24
| apache2-mod_spdy | package | 0.9.1.5-1.1 | x86_64 | apache24
c-3po:~/bin # zypper in apache2-mod_spdy
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: apache2-mod_spdy-0.9.1.5-1.1.x86_64 requires apache2(mod_ssl+npn),
but this requirement cannot be provided
uninstallable providers: apache2-2.2.22-10.1.1.i586[repo-oss]
apache2-2.2.22-10.1.1.x86_64[repo-oss]
apache2-2.2.22-10.4.1.i586[updates]
apache2-2.2.22-10.4.1.x86_64[updates]
Solution 1: Following actions will be done:
downgrade of apache2-2.4.4-3.1.x86_64 to apache2-2.2.22-10.4.1.x86_64
install apache2-2.2.22-10.4.1.x86_64 (with vendor change)
obs://build.opensuse.org/Apache --> openSUSE
downgrade of apache2-devel-2.4.4-3.1.x86_64 to apache2-
devel-2.2.22-10.4.1.x86_64
install apache2-devel-2.2.22-10.4.1.x86_64 (with vendor change)
obs://build.opensuse.org/Apache --> openSUSE
downgrade of apache2-event-2.4.4-3.1.x86_64 to apache2-
event-2.2.22-10.4.1.x86_64
install apache2-event-2.2.22-10.4.1.x86_64 (with vendor change)
obs://build.opensuse.org/Apache --> openSUSE
downgrade of apache2-prefork-2.4.4-3.1.x86_64 to apache2-
prefork-2.2.22-10.4.1.x86_64
install apache2-prefork-2.2.22-10.4.1.x86_64 (with vendor change)
obs://build.opensuse.org/Apache --> openSUSE
downgrade of apache2-worker-2.4.4-3.1.x86_64 to apache2-
worker-2.2.22-10.4.1.x86_64
install apache2-worker-2.2.22-10.4.1.x86_64 (with vendor change)
obs://build.opensuse.org/Apache --> openSUSE
deinstallation of apache2-mod_bmx-0.9.4-1.1.x86_64
downgrade of apache2-mod_fcgid-2.3.7-25.2.x86_64 to apache2-
mod_fcgid-2.3.6-11.1.1.x86_64
install apache2-mod_fcgid-2.3.6-11.1.1.x86_64 (with vendor change)
obs://build.opensuse.org/Apache --> openSUSE
downgrade of apache2-mod_macro-1.2.1-408.1.x86_64 to apache2-
mod_macro-1.1.8-209.1.1.x86_64
install apache2-mod_macro-1.1.8-209.1.1.x86_64 (with vendor change)
obs://build.opensuse.org/Apache --> openSUSE
install apache2-mod_musicindex-1.4.1-3.1.x86_64 (with vendor change)
obs://build.opensuse.org/Apache --> http://packman.links2linux.de
downgrade of apache2-mod_perl-2.0.7+svn1448242-26.2.x86_64 to apache2-
mod_perl-2.0.6-5.1.1.x86_64
install apache2-mod_perl-2.0.6-5.1.1.x86_64 (with vendor change)
obs://build.opensuse.org/Apache --> openSUSE
deinstallation of apache2-mod_telemetry-1.0-4.1.x86_64
Solution 2: do not install apache2-mod_spdy-0.9.1.5-1.1.x86_64
Solution 3: do not install apache2-mod_spdy-0.9.1.5-1.1.x86_64
Solution 4: break apache2-mod_spdy-0.9.1.5-1.1.x86_64 by ignoring some of its
dependencies

Choose from above solutions by number or cancel [1/2/3/4/c] (c):

Thanks for the packaging otherwise.


--

Bruno Friedmann
Ioda-Net Sàrl www.ioda-net.ch

openSUSE Member & Ambassador
GPG KEY : D5C9B751C4653227
irc: tigerfoot
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups