Mailinglist Archive: opensuse-packaging (266 mails)

< Previous Next >
Re: [opensuse-packaging] How can I access BuildRequires for the Debian build process?
  • From: Krzysztof Żelechowski <giecrilj@xxxxxxxxxxxx>
  • Date: Fri, 16 Nov 2012 21:10:53 +0100
  • Message-id: <1956121.golGZBNHTP@linux-d902>
Dnia piątek, 16 listopada 2012 15:04:07 Jeremias Brödel pisze:
Hey,

I am trying to build php5-pear-Horde_Autoloader for Debian 6. The build
requiers are debian's pkg-php-tools, which I provide in
server:php:applications. Sadly it gets unresolvable messages.

"Nothing provides update-alternatives".

I doubt that there is no update-alternatives package in the Debian 6
Build target. How can I access this?

https://build.opensuse.org/package/show?package=pkg-php-tools&project=server
%3Aphp%3Aapplications#

What should I do to build pkg-php-tools against debian squeeze?

Thanks,

Jeremias

You need to clone update-alternatives from Factory and let it build for
Debian. You will probably have to write a build script for it yourself
though.

IMHO,
Chris.
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References