Mailinglist Archive: opensuse-packaging (266 mails)

< Previous Next >
[opensuse-packaging] Issues with building Chromium due to ffmpeg dependency
Since the last two weeks, I gained new issues while building Chromium on OBS.
The reason for these new issues is the old story with ffmpeg. However recent
changes in Chromium itself, makes it now necessary that the libraries (avutil,
avconfig, etc) are present as that parts of Chromium are now build against the
ffmpeg libraries.

I have tried to move around this, but got stuck. I also tried using the
libffmpeg-devel created by Elvigia, but these cause for some forward
declarations issues. Therefore I see only two ways moving forward and I would
appreciate your feedback on them in order to decide what is the best method.

Method 1 is to move Chromium out of the openSUSE OBS and move the package to
packman, so that it can build with all internal libraries. This would remove
the need for the chromium-ffmpeg package which is already build on packman.

Method 2 would be to build Chromium on the openSUSE OBS with the internal
ffmpeg sources and then to remove the resulting ffmpeg library (which can be
retrieved from packman).

As far as I know it wouldn't even be allowed to put the ffmpeg sources up on
OBS, but I could be wrong here. There my question :-)

This also impacts the maintenance of Chromium for 12.1 and 12.2.

Thanks

Regards

Raymond
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups