Mailinglist Archive: opensuse-packaging (267 mails)

< Previous Next >
Re: [opensuse-packaging] How to detect package's version in specfile?
Hi,

I've missed that thread but just noticed something about xulrunner and
Tumbleweed.

Am 01.11.2012 16:17, schrieb Marguerite Su:
eg: xulrunner-devel is not available in <=1210. and Tumbleweed is the
only one have 14.0.1 version. (12.2 is 16.0.1 and Factory is 16.0.2)

Tumbleweed has the xulrunner version inherited from 12.2 and the only
reason why Tumbleweed has no update in itself is that Tumbleweed users
are meant to have the 12.2 update repo enabled.
xulrunner > 10.0.10 and < 16.0.2 is not supported and contain security
issues.

so:

%if 0%{?suse_version} >= 1220
%if 0%{?xulrunner_version} < 15
// Now you're in Tumbleweed env
%endif
%endif

That can also be 12.2 if you build against 12.2 and not against the 12.2
update repository. Therefore I do not think this is the right package to
check for.

I also have no good idea how to detect Tumbleweed btw.


Wolfgang
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation