Mailinglist Archive: opensuse-packaging (99 mails)

< Previous Next >
Re: [opensuse-packaging] Dependency resolution problem
Am 20.10.2012 16:21, schrieb Nanuk Krinner:
Hi,

I'm working on the project systemsmanagement:chef and have a problem
where I need help.

Every package builds against openSUSE 12.2 in the build service. But
when I try to build rubygem-chef-solr from the project locally (with
'osc build x86_64 openSUSE_12.2') or install it I get the following error:

#:~/work/packaging/systemsmanagement:chef/rubygem-chef-solr> osc build
x86_64 openSUSE_12.2
Building rubygem-chef-solr.spec for openSUSE_12.2/x86_64
Getting buildinfo from server and store to
/home/nanuk/work/packaging/systemsmanagement:chef/rubygem-chef-solr/.osc/_buildinfo-openSUSE_12.2-x86_64.xml

Getting buildconfig from server and store to
/home/nanuk/work/packaging/systemsmanagement:chef/rubygem-chef-solr/.osc/_buildconfig-openSUSE_12.2-x86_64

buildinfo is broken... it says:
unresolvable: nothing provides rubygem(1.9.1:net-ssh-multi:1.1) >= 1.1.0
needed by rubygem-chef


The version is 1.1, but is compared to 1.1.0. I didn't want to pollute
the provides namespace more than necessary and so we only support ~>
operator only if it makes sense. And gem is the first one to use things
like ~> 1.1.0 when the version is 1.1 - I guess the .0 is implied with
ruby. Hmm, not sure what's the best solution is.

Greetings, Stephan

--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
References