Mailinglist Archive: opensuse-packaging (99 mails)

< Previous Next >
[opensuse-packaging] Dependency resolution problem
Hi,

I'm working on the project systemsmanagement:chef and have a problem where I need help.

Every package builds against openSUSE 12.2 in the build service. But when I try to build rubygem-chef-solr from the project locally (with 'osc build x86_64 openSUSE_12.2') or install it I get the following error:

#:~/work/packaging/systemsmanagement:chef/rubygem-chef-solr> osc build x86_64 openSUSE_12.2
Building rubygem-chef-solr.spec for openSUSE_12.2/x86_64
Getting buildinfo from server and store to /home/nanuk/work/packaging/systemsmanagement:chef/rubygem-chef-solr/.osc/_buildinfo-openSUSE_12.2-x86_64.xml
Getting buildconfig from server and store to /home/nanuk/work/packaging/systemsmanagement:chef/rubygem-chef-solr/.osc/_buildconfig-openSUSE_12.2-x86_64
buildinfo is broken... it says:
unresolvable: nothing provides rubygem(1.9.1:net-ssh-multi:1.1) >= 1.1.0 needed by rubygem-chef

But I can build rubygem-chef and rubygem-net-ssh-multi locally. When I try to install rubygem-chef, it fails with same error as does rubygem-chef-solr. But I can install rubygem-net-ssh-multi (and other packages) from the repository.

I don't understand why everything works within the build service, but I can't install from the repository. There might be a problem in the project config or in one of the spec files, but don't see it.

Does anybody what is wrong here?

Thanks in advance,
Nanuk
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups