Mailinglist Archive: opensuse-packaging (140 mails)

< Previous Next >
Re: [opensuse-packaging] %if 0%{?suse_version} >= 1210 not working?
On 01/02/2012 10:46 AM, Lutz Thuns wrote:
Am 02.01.2012 10:31, schrieb Andreas Jaeger:

I just checked the "Meta Configuration of X11:lxde" (via
https://build.opensuse.org/project/meta?project=X11%3Alxde), it shows
starting at line 29:
<repository name="openSUSE_12.1">
<path repository="standard" project="openSUSE:11.4"/>
<arch>x86_64</arch>
<arch>i586</arch>
</repository>

So, somebody screwed up and use a repository called 12.1 that builds
against 11.4. Please fix the above and recompile everything - and I
expect it works again.


Hi Andreas,

thanks for investigating.
According to my meta [1] which is set correctly, it should at least work
for my OBS branch right?
Unfortunately it doesn't.

It should - but maybe there's some problem since you build against the lxde repository and something is inherited.

Do you reproduce this with a package build against openSUSE:12.1 locally?

I mean something like:
osc --alternative-project=openSUSE:12.1 your-spec.spec ?

Andreas
--
Andreas Jaeger aj@{suse.com,opensuse.org} Twitter/Identica: jaegerandi
SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg, Germany
GF: Jeff Hawn,Jennifer Guild,Felix Imendörffer,HRB16746 (AG Nürnberg)
GPG fingerprint = 93A3 365E CE47 B889 DF7F FED1 389A 563C C272 A126
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups