Mailinglist Archive: opensuse-packaging (144 mails)

< Previous Next >
Re: [opensuse-packaging] cups: upgrade from 1.4.x to version 1.5.0
On 03.11.2011 16:48, Werner Flamme wrote:

Stefan Seyfried [03.11.2011 16:07]:
Hi Johannes,

On 03.11.2011 14:38, Johannes Meixner wrote:

Is this really a new issue since CUPS 1.5.x (i.e. it worked with

I'm pretty sure I had seen something like that on 11.4 or earlier
when I had "print" in /etc/hosts and tried to access it as
"print.domain". Adding all aliases of the server, including FQDNs
to /etc/hosts made it work IIRC.

All print servers are in DNS with their FQDN, and the error came up on
all clients that tried to contact the print servers via FQDN. As soon
as they switched to using the short name, everything went well.

The DNS translates short name and FQDN to exactly the same address.

In my case it was the same. I needed to put them into /etc/hosts. I did
not investigate it more deeply, just putting everything into /etc/hosts
did work for me.

I just wanted to spell out that this does not have to be a CUPS 1.5
issue, but that I had seen similar things in 1.4

BTW, if DNS could not resolve the FQDN, IMHO I'd never get "Bad
request", but "Connection timed out" or "Server not found" :-(

This is not a DNS issue but has to do with who the cups server thinks he
Stefan Seyfried

"Dispatch war rocket Ajax to bring back his body!"
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups