Mailinglist Archive: opensuse-packaging (107 mails)

< Previous Next >
Re: [opensuse-packaging] Need help by Fixing Bugreports
  • From: oc2pus@xxxxxxxx
  • Date: Thu, 14 May 2009 13:43:42 +0200
  • Message-id: <200905141343.43020.oc2pus@xxxxxxxx>
Am Donnerstag, 14. Mai 2009 schrieb Sascha 'saigkill' Manns:
Hi Mates,

no i've modified the Spec to the following (Full Spec attatched):

%files -n libskgbankgui1
%defattr(-, root, root)
%{_libdir}/libskgbankgui.so.*

%files -n libskgbankmodeler1
%defattr(-, root, root)
%{_libdir}/libskgbankmodeler.so.*

%files -n libskgbasegui1
%defattr(-, root, root)
%{_libdir}/kde4/plugins/designer/libskgbasegui.so
%{_libdir}/libskgbasegui.so.*

%files -n libskgbasemodeler1
%defattr(-, root, root)
%{_libdir}/libskgbasemodeler.so.*

%files devel
%defattr(-, root, root)
%{_libdir}/libskgbankgui.so
%{_libdir}/libskgbankmodeler.so
%{_libdir}/libskgbasegui.so
%{_libdir}/libskgbasemodeler.so

%files lang -f %{realname}.lang
%defattr(-, root, root)

Actual Results:
* i've set the Priority from KDE:KDE4:Community to "89" and Packman to
"99"
* If i now choose kde4-skrooge Yast choose the following:
+ all 4 libskg* Packages
+ lang Package
+ devel Package
* After install all via Yast i'm get the Error:
sascha@linux-eh47:~/osc/home:saigkill/kde4-skrooge> skrooge
skrooge: error while loading shared libraries: libskgbasegui.so.1:
cannot open shared object file: No such file or directory
libskgbasegui.so.1 is only a link ... so it can't work
or you install the devel package
That's the reason yast pulls in the devel package. And your devel-package is
missing Requires, nomally all packages you need as BuildRequires for the main
package should be required by the devel-package as Requires.
And than, your devel package will pull in a lot of devel packages as long as
you don't change the links for libsk*
==> libskgbasegui.so.1 must be a real file and libskgbasegui.so is a link to
it.

* Now i'm going to Yast. If i type skrooge in the Searchfield, i see
that he installed all from KDE:KDE4:Community. But: kde4-skrooge, devel
and lang was installed in Version 0.2.8-21.1 (my last Release). But all
libskg* Files are installed in Version 0.2.8-17.1 (marked in blue).

* After updating these 4 Files skrooge works.
do a real test:
remove all packages AND remove all old files from former installations. Than
try to reinstall and you'll see it won't work as libskgbasegui.so.1 is only
a link.

have fun
Toni
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups