Mailinglist Archive: opensuse-packaging (186 mails)

< Previous Next >
[opensuse-packaging] Packaging issue / question for libproxy in Factory
  • From: "Dominique Leuenberger" <Dominique.Leuenberger@xxxxxxxxxxxxx>
  • Date: Mon, 23 Feb 2009 13:21:00 +0100
  • Message-id: <49A2A2BC020000290001146B@xxxxxxxxxxxxxxxxxxx>
Hi everybody...

I guess -packaging might be the best list to ask for this.

Situation:
We have libproxy in factory. libsoup depends on it. libproxy is enhanced with
several plugins, which are installed by using 'Supplemnts:packageand()
tags. (package openSUSE:Factory/libproxy)

Everything works fine (so far)... now the tricky part:
libsoup exists as libsoup-32bit package (for compatibility).
It requires libproxy, thus it was created as baselib -> libproxy0-32bit

Not the real problem: how to get all the plugins also installed together with
libprox0-32bit? And how to have their Supplements: tag correctly
updated?

Example:
libproxy0-gnome has
Supplements: packageand:libproxy0:gconf2)

which results that libproxy0-gnome-32bit should get
supplements: packageand(libproxy0-32bit:gconf2-32bit)

Any tricks on how to achieve this ?

Dominique
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages