Mailinglist Archive: opensuse-packaging (83 mails)

< Previous Next >
Re: [opensuse-packaging] Automatically install a specific package for build
  • From: Marcus Meissner <meissner@xxxxxxx>
  • Date: Sat, 25 Oct 2008 12:12:44 +0200
  • Message-id: <20081025101243.GA6190@xxxxxxx>
On Sat, Oct 25, 2008 at 12:09:02PM +0200, Bernhard Walle wrote:
* Magnus Boman [2008-10-25 19:59]:

Trying to build the latest GNOME for openSUSE 11.0. A fair amount of
those packages (~150) seem to require pcre-devel to be able to build
(which is not the case on Factory).
Is there an easy way to tell OBS to automatically install this package
during build for a specific project?

What is the advantage compared with BuildRequires?

And perhaps the -devel package that requires pcre-devel should require it.
(gtk2-devel? or glib2-devel? was the culprit I think).

Ciao, Marcus
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups