Mailinglist Archive: opensuse-packaging (83 mails)

< Previous Next >
Re: [opensuse-packaging] RPM version ordering
  • From: Dirk Müller <dmueller@xxxxxxx>
  • Date: Tue, 14 Oct 2008 16:17:08 +0200
  • Message-id: <200810141617.08547.dmueller@xxxxxxx>
On Tuesday 14 October 2008, Michael Schroeder wrote:

(But as said before: dist-upgrade has no problems with downgrading.
Just be sure that there's no repository still enabled with the
old version.)

As long as we make clear that this is the policy, I'm fine with that. so far I
didn't know that this is an invalid (unspported) setup. with the shared
library policy in place more users will have older distributions as addon
repository in their sources list, therefore I think my bugreport is valid. it
is the most sensible solution imho. in that situation, the current
distribution upgrade algorithmn will pick the 11.0 package even though it is
from an older code stream, which is why I filed the bugreport.

I read somewhere that

Provides: python-openssl > 0.7a

would help with the version downgrade.

Feel free to close it if we declare this setup as "broken".

Greetings,
Dirk

--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >