Mailinglist Archive: opensuse-packaging (111 mails)

< Previous Next >
[opensuse-packaging] KMPs do not build on Factory i586
  • From: "Dominique Leuenberger" <Dominique.Leuenberger@xxxxxxxxxxxxx>
  • Date: Wed, 02 Apr 2008 09:13:54 +0200
  • Message-id: <47F34E52.2554.0029.1@xxxxxxxxxxxxx>
Hi everybody,

as on -buildservice, apparently nobody knows about this problem and I was
advised to bring it here: so here my question again:
Is there something wrong in Factory? The %suse_kernel_module_package seems not
to fill up $falvors_to_build anymore and thus the routing to itterate over all
flavors and build the respecting module does not work.

Anything broken at mine ? See reference below.

Dominique

On 4/1/2008 at 10:54, "Dr. Peter Poeml" <poeml@xxxxxxx> wrote:
Hello Dominique,


On Tue, Mar 25, 2008 at 10:46:11AM +0100, Dominique Leuenberger wrote:
Hello,

I see that no KMP is being built on factory i586 (still works against
x86_64).

The problem actually seems to be, that this code snip does not work anymore:
for flavor in %{flavors_to_build}; do
rm -rf obj/$flavor
cp -r %{name}-%{version}-%{svn_rev} obj/$flavor
pushd obj/$flavor
make modules
popd
done

I checked several KMPs, and they all skip the for flavor in
%{flavors_to_build}.. so I assume that %flavor_to_build is no longer
populated...

Is it a small thing and can be fixed like this, or shall I file a bugzilla
entry? Against what category would it be?

Dominique

Have you asked on the opensuse-packagers list? Maybe you are lucky
there.

I'm sorry I can't give better advice.

Anybody else, maybe?

Adrian, anything special with regard to Factory maybe?

Peter




< Previous Next >
List Navigation
Follow Ups