Mailinglist Archive: opensuse-packaging (49 mails)

< Previous Next >
Re: [opensuse-packaging] Re: [game] Dark Oberon
  • From: Pavol Rusnak <prusnak@xxxxxxx>
  • Date: Tue, 19 Jun 2007 10:14:13 +0200
  • Message-id: <46779055.2080408@xxxxxxx>
Ladislav Michnovič wrote:
> The problem is the game needs libraries which are not packaged yet.
> Namely: GLFW 2.5 (http://glfw.sourceforge.net/)
>              and  FMOD (http://fmod.org/) which is available in PackMan
> repo.
> Maybe we can put them in games:libs. I am offering a help.

If you had looked into BuildService, you would have seen that these libs
are already in this OBS project. There is no problem with GLFW, but
there are with FMod. There is an older branch called FMod (3.75), which
is distributed only in binary form and only for x86. I wrote to
developers and they have no intention to release binaries for x86_64 as
they are concentrating on newer version called FMODex (currently at
4.06.20). So basically there are 3 options (not counting license problems):

a) leave Dark Oberon as it is, linked against 32bit FMOD
b) rewrite Dark Oberon to use new FMODex API (also available for 64bit)
c) rewrite Dark Oberon to use another audio library

-- 
Best Regards / S pozdravom,

Pavol RUSNAK                                       SUSE LINUX, s.r.o
Package Maintainer                                Lihovarska 1060/12
PGP 0xA6917144                                     19000 Praha 9, CR
prusnak[at]suse.cz                                http://www.suse.cz
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >