Mailinglist Archive: opensuse-packaging (138 mails)

< Previous Next >
Re: [opensuse-packaging] Trouble with the neededforbuild macro
  • From: Marcus Rueckert <darix@xxxxxx>
  • Date: Wed, 21 Mar 2007 14:39:53 +0100
  • Message-id: <20070321133953.GG22086@xxxxxxxxxxxxxxxxxxxxxxx>
On 2007-03-21 14:34:56 +0100, Ladislav Michnovič wrote:
> IMHO it should be
> %if %suse_version > 1000
> BuildRequires: ...
> %else
> # neededforbuild ...
> %endif

why?

your line will fail on fedora e.g., while michal's line works there
aswell.

and often the buildrequires works without a version specific part.
and when using the buildservice it might even work on all distros.

that said i would leave out all %if in first place. ;)

darix

--
openSUSE - SUSE Linux is my linux
openSUSE is good for you
www.opensuse.org
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups