Mailinglist Archive: opensuse-packaging (138 mails)

< Previous Next >
Re: [opensuse-packaging] Trouble with the neededforbuild macro
  • From: Jules Colding <colding@xxxxxxxxx>
  • Date: Wed, 21 Mar 2007 12:46:58 +0100
  • Message-id: <1174477619.6271.233.camel@xxxxxxxxxxxxxxx>
On Wed, 2007-03-21 at 11:07 +0100, Michal Marek wrote:
> Jules Colding wrote:
> > I've experimented with the neededforbuild macro instead of adding
> > additional BuildRequires statements. This unfortunately makes 'build'
> > complain about failed build dependencies.
>
> You shouldn't use # neededforbuild anymore. The build script supports it
> only to be able to rebuild build packages from SUSE Linux <= 10.0, but
> then it disregards BuildRequires:.

OK, that explains my observations.


> %if 0%{?suse_version}
> BuildRequires: ...
> %endif

What does 0%{?suse_version} do? Does it only evaluates to true if
suse_version is defined or something like that??


> is the way to go.

Thanks,
jules


---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups