Mailinglist Archive: opensuse-packaging (138 mails)

< Previous Next >
[opensuse-packaging] Trouble with the neededforbuild macro
  • From: Jules Colding <colding@xxxxxxxxx>
  • Date: Wed, 21 Mar 2007 10:59:53 +0100
  • Message-id: <1174471193.6271.214.camel@xxxxxxxxxxxxxxx>
Hi,

I'm trying to build an evolution-brutus (e-b) RPM in OpenSUSE 10.2.

A few additional packages are required for e-b to build in OpenSUSE as
opposed to Fedora for which the spec file is originally developed. The
additional packages are:

mDNSResponder-lib
lsb
gnome-common
libidl-devel

I've experimented with the neededforbuild macro instead of adding
additional BuildRequires statements. This unfortunately makes 'build'
complain about failed build dependencies.

In other words - it works if I add additional BuildRequires statements:

BuildRequires: mDNSResponder-lib
BuildRequires: lsb
BuildRequires: gnome-common
BuildRequires: libidl-devel

But it does not work if I use the neededforbuild macro like this:

# neededforbuild mDNSResponder-lib lsb gnome-common libidl-devel

Any ideas?

Thanks,
jules


---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >