Mailinglist Archive: opensuse-packaging (74 mails)

< Previous Next >
Re: [opensuse-packaging] Automatically installing "plugins" via dependencies
  • From: Reinhard Max <max@xxxxxxx>
  • Date: Wed, 14 Jun 2006 11:23:59 +0200 (CEST)
  • Message-id: <Pine.LNX.4.64.0606141112240.13233@xxxxxxxxxxxxxx>
Hi,

On Wed, 14 Jun 2006 at 10:49, Adrian Schröter wrote:

> It is anyway not really good, when jabberd is the only exception
> where the user has to manually find that out while all other
> packages are package in a different way, where this is not needed.

it wouldn't be any different with the other proposed solution (set the
dependencies of the plugin subpackage so, that it will be installed
when the main package and the respective database library are
installed), because the user still has to know that he must install
the database library in order to get the plugin installed.

Also, who says, that when somebody has installed jabberd and, say, the
MySQL client libraries, that he actually wants to use MySQL as the
storage backend for jabberd (and hence needs the MySQL plugin), and
not PostgreSQL, SQLite, or something else. Only the user knows this,
and that's why automatic dependencies and/or subpackages just don't
make sense for this package when looking for the best tradeoff between
ease of use, packaging complexity and space requirements.

BTW, I talked to Rudi and aj before submitting this modification to
the jabberd package, and got their OK to give it a try.

cu
Reinhard

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-packaging-unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging-help@xxxxxxxxxxxx

< Previous Next >
Follow Ups