Mailinglist Archive: opensuse-packaging (74 mails)

< Previous Next >
Re: [opensuse-packaging] Automatically installing "plugins" via dependencies
  • From: Stanislav Brabec <sbrabec@xxxxxxx>
  • Date: Tue, 13 Jun 2006 13:47:05 +0200
  • Message-id: <1150199225.27840.51.camel@xxxxxxxxxxxxxx>
Reinhard Max wrote:
> Hi,
>
> I recently had the same problem with the jabberd package. It supports
> a variety of database backends, but I didn't want to add all those
> libraries to the dependency list of the package, and I didn't want to
> add half a dozen plugin packages that contain more metadata than
> payload.

I did the same for inkscape and planner packages, but did an additional
triggers to enable these plugins only if dependent packages are
installed.

For more see these spec file in 10.1.

Note that you may want to copy and paste %triggerin to %post (it looks
so, needs re-check) and %triggerpostun to %postun (probably not
required, needs re-check) - see planner.spec.

--
Best Regards / S pozdravem,

Stanislav Brabec
software developer
---------------------------------------------------------------------
SuSE CR, s. r. o. e-mail: sbrabec@xxxxxxx
Drahobejlova 27 tel: +420 296 542 382
190 00 Praha 9 fax: +420 296 542 374
Czech Republic http://www.suse.cz/


---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-packaging-unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging-help@xxxxxxxxxxxx

< Previous Next >