Mailinglist Archive: opensuse-multimedia (12 mails)

< Previous Next >
Sound problem - works with some apps not others
  • From: Steve King <steveoldmanse-suselinuxe@xxxxxxxxxxx>
  • Date: Sat, 26 Feb 2005 20:51:59 +0000 (GMT)
  • Message-id: <20050226205200.37846.qmail@xxxxxxxxxxxxxxxxxxxxxxxxxxx>

I have 2 PCs running Suse 9.2. The older one works
fine, but this second has probems with sound. The
problems are:

- some apps do not work: amarok and xine in
particular. Amarok gives the impression of being
"stuck": the progress counter does not move off 0:00.
What makes this odd is that other apps do play sound:
xmms, grip, ogle.

- when I use the "test" button in Yast2 soundcard
set-up, it too seems to get stuck. It plays a sound,
but instead of the full sample, it plays the first
chord and a bit of the next, over and over and over
again. I get the same with alsaconf.

lspci says that the soundcard is VIA Technologies,
Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev

This is consistent with what the soundcard set up

(The PC that works has Multimedia audio controller:
VIA Technologies, Inc. VT82C686 AC97 Audio Controller
(rev 20))

I have tried various settings for ac97_quirk and
dxs_support, but while these change the quality of the
sound, the test sample is still "stuck" (expect for
some which remove it altogether).

I have tried adding and removing modules snd_via82xx
and via82cxxx_audio, but no improvement. (By default,
snd_via82xx is active and via82cxxx_audio is not.)

Has anyone got any ideas on this? The 2 PCs use NIS
etc so that the family can use either and get the same
environment ... except that if we forget which app it
is OK to use (and remember not to play mpeg4 files on
the affected machine at all), we can crash everything.


Dundee, UK

< Previous Next >
This Thread
  • No further messages