Mailinglist Archive: opensuse-mobile-de (414 mails)

< Previous Next >
Re: [suse-laptop] Wie kann ich ein PCMCIA Netwerkkartentreibermodul automatisch laden?
  • From: Dominik Zindel <dominik@xxxxxxxxxx>
  • Date: Thu, 8 Jan 2004 11:13:21 +0100
  • Message-id: <200401081113.21448.dominik@xxxxxxxxxx>
Hallo Liste

Ich hatte ein ähnliches Problem: Meine WLAN-PCMCIA-Card musste ich immer durch
Eingabe von ca. 5 Zeilen von Hand aktivieren. Und zwar als root.
Nun habe ich die Befehle in die Datei file:/etc/rc.d/rc eingetragen (ich hab
sie einfach am Schluss hinzugefügt). Nun werden diese Aktivierungsbefehle
beim Systemstart (noch als root) immer ausgeführt. Hat natürlich den
Nachteil, dass die Karte beim Starten im Slot sein muss.
Bin mir auch bewusst, dass dies wohl nicht die perfekte Lösung ist - aber sie
funktioniert bei mir...

Gruss

Dominik

Am Donnerstag, 8. Januar 2004 10:26 schrieb Edgar Piskernik:
> Liebe Liste!
>
> Nach vielen Stunden Recherche habe ich meine Realtek 8139 PCMCIA
> Netzwerkkarte (eine Surecom 428X 10/100 MBit) endlich zum laufen
> gebracht. Die Karte wird zwar von Yast richtig erkannt (Realtek 8139)
> aber das entsprechende Modul wird offensichtlich nicht geladen. Wie
> kann ich Suse Linux bzw. hotplug dazu bewegen, die unten angeführten
> Maßnahmen (vor allem modprobe rtl8139) beim Anschliessen der Karte
> richtig durchzuführen?
>
> Situation:
> Die Netwerkkarte wurde von mir in Yast 2 als eth-pcmcia mit den
> richtigen Angaben versehen (IP, Gateway usw.)
> ifconfig bringt nur lo, ein ping auf lo ist problemlos möglich.
> eth0 ist mit ifconfig nicht sichtbar.
>
> Mein Vorgehen war folgendermaßen:
>
> modprobe rtl8139
> #also offensichtlich nicht mehr rtl8139too wie in der Supportdatenbank
> für Kernel 2.4 beschrieben?
>
> ifconfig -a
> # zeigt nun die Karte als eth0 ohne Einstellungen
>
> ifconfig eth0 <IP ADRESSE> netmask 255.255.255.0 broadcast
> <BROADCAST Adresse = wahrscheinlich IP mit letzer Stelle 255>
>
> route -n #zeigt nichts
>
> #folgende Route habe ich später in die Datei routes eingetragen und
> müssen nun nicht mehr manuell gestartet werden.
>
> route add -net 127.0.0.0 netmask 255.255.255.0 dev lo
> route add default gw <IP ADRESSE GATEWAY>
>
> #Nach einem
> rcnetwork restart
> #funktioniert die Netwerkverbindung dann.
>
> Zu meinem System:
> Toshiba 7200ct mit Pentium III-M Speedstep mit 600MHz
> Suse Linux 9.0 mit Kernelupdate vom 16. Dezember (166)
> Surecom 428X PCMCIA Netzwerkkarte (Realtek 8139)
>
> Hat jemand eine Idee?
>
> Danke,
>
> Edgar

--
------
Dominik Zindel
rte Bel-Air 24
1723 Marly
Tel 026 436 48 50
Natel 079 207 00 65
dominik@xxxxxxxxxx
www.zindel.org
ICQ 346494515


< Previous Next >
Follow Ups
References