Mailinglist Archive: opensuse-mobile-de (380 mails)

< Previous Next >
Re: [suse-laptop] [Fehler erkannt] Luefter unter SuSE 8.0 und SuSE 7.3
  • From: Steffen Petter <spetter@xxxxxx>
  • Date: Sat, 9 Nov 2002 01:39:01 +0100
  • Message-id: <200211090139.02149.spetter@xxxxxx>
Am Freitag, 8. November 2002 16:01 schrieb Steffen Petter:
> Hallo zusammen,
>
> also das Problem mit der defekten Lüftersteuerung auf dem Clevo 2700C
> (BayCom WorldBook 2) mit SiS 630S unter SuSE-8.0 mit Kernel
> 2.4.19-4GB besteht immer noch.
>
> Bezug auf:
> http://lists.suse.com/archive/suse-laptop/2002-Nov/0070.html und
> http://lists.suse.com/archive/suse-laptop/2002-Oct/0334.html

Nun Nicht mehr, der Fehler wurde entdeckt, siehe unten!

>
> 4.) Tja, voran liegts denn nun! APM ist vorhanden und funktioniert
> ganz gut. ACPI ist immer ausgeschaltet (acpi=off), da dies zum einen
> in Version 1.0b im Bios implementiert ist und zum anderen von Linux
> noch nicht vollständig unterstützt wird. Mein Verdacht, dass es an
> irgend einem Modul oder Dienst liegen könnte, bestätigte sich, da ich
> beim nächsten Kaltstart einfach mal im Single-User Modus
> (Systemverwaltungsmodus) mittels Bootparameter "single" das OS
> startete. Zuvor hatte ich mir noch ein Benchmarking-Tool, nämlich
> "bogomips" besorgt und kompiliert. Dieses Programm habe ich nun zur
> Erhöhung der Prozessorlast und demzufolge zur Erhöhung der
> CPU-Temperatur eingesetzt. Und siehe da, der Lüfter sprang an, wenn
> es der CPU zu heiß wurde und ging wieder aus, wenn es ihr wieder
> kühler wurde. Die Steuerung des Lüfters funktioniert also im
> Single-User Modus.
> Ein Blick auf die geladende Module zeigte folgende Liste:
> usb-ohci
> usb-core
> reiserfs
> ide-scsi
>
> Frage(n):
> Welcher Dienst oder welches Modul/Gerät stört denn nun die
> Lüftersteuerung? Kennt jemand ein effizientes Vorgehen, wie man so
> etwas herausbekommt?

Das fragliche Modul was die Lüftersteuerung unterbunden bzw. gestört
hat, habe ich in mühevoller Kleinarbeit nach dem Try-and-Error Prinzip
nun entdeckt, nämlich das Modul "lp", welches für das Drucken über den
Parallelport zuständig ist. Dies wird durch das Startscript des
jeweiligen Druckdienstes, bei mir "cups", geladen. Es ist abhängig vom
Modul "parport". Die Ausgabe von dmesg verriet mir folgendes:
parport0: PC-style at 0x378 [PCSPP,EPP]
lp0: using parport0 (polling)

Auch die Umstellung der IO-Adresse und das Hinzuschalten von EPP bzw.
ECP im BIOS bewirkte keine Besserung im Hinblick auf die
Lüftersteuerung. Erst als ich den Druckdienst (cupsd), der ja das Laden
benannter Module veranlasst, aus allen Runleveln entfernte und danach
einen Kaltstart vollführte, funktionierte die Lüftersteuerung
einwandfrei. Der Rechner wird jetzt nicht mehr zur mobilen Kochplatte!
;-)

Bloß kann ich jetzt nicht mehr drucken! :-(
Hat jemand eine Idee, welche Einstellungsmöglichkeiten man bei den
Modulen "lp" und "parport" hat ?
Wenn ich schon nicht über den Parallelport drucken kann, so will ich
doch wenigstens einen entfernten Netzdrucker bedienen können. Kann man
"cups" so einstellen, dass er nicht die Module für den Paralellport
läd, aber trotzdem das "entfernte" Drucken unterstützt? Wenn ja, wie?


Hier noch eine kurze Zusammenfassung für etwaige Leidensgenossen oder
fleißige Supportler ;-) :

Problem:
Der Lüfter im Notebook schaltet sich nicht ein bzw. nicht mehr aus. -->
Lüftersteuerung defekt.
Betrifft:
SuSE 8.0 , Kernel 2.4.18-4GB und folgende, Notebook Clevo 2700c mit SiS
630S Chipsatz (u.a. Baycom Worldbook 2) - Systemsoft SystemBios
MobilPro 1.01
Diagnose:
Das Kernelmodul "lp", verantwortlich für das Drucken über den LTP-Port
verhindert die Kommunikation zur Lüftersteuerung. Das Notebook wird
entweder im laufenden Betrieb, durch die fehlende Kühlung, immer heißer
bis der Überhitzungsschutz den Rechner einfach abschaltet. Oder nach
vorherigem Betrieb und anschließendem Neustart schaltet sich der Lüfter
beim Booten (durch das BIOS) wieder ein, wird aber im laufenden Betrieb
nicht mehr ausgeschaltet, obwohl die Temperatur der CPU merklich
gesunken ist.
Abhilfe (provisorisch):
Abschalten der Druckerdienste z.B.in den Runleveln.



Nach ca. 3-monatiger Suche und "Bastelei" ist es mir nun endlich
gelungen, den Fehler zu finden. Darauf ein Flasche Wein!

Gruß,
Steffen

< Previous Next >
References