Mailinglist Archive: opensuse-mobile-de (380 mails)

< Previous Next >
Re: [suse-laptop] [Fehler erkannt] Luefter unter SuSE 8.0 und SuSE 7.3
  • From: Steffen Petter <spetter@xxxxxx>
  • Date: Mon, 11 Nov 2002 10:10:05 +0100
  • Message-id: <200211111010.06128.spetter@xxxxxx>
Am Montag, 11. November 2002 08:10 schrieb Rainer Hantsch:
> On Sat, 9 Nov 2002, Steffen Petter wrote:
> | Bloß kann ich jetzt nicht mehr drucken! :-(
> | Hat jemand eine Idee, welche Einstellungsmöglichkeiten man bei den
> | Modulen "lp" und "parport" hat ?
> | Wenn ich schon nicht über den Parallelport drucken kann, so will
> | ich doch wenigstens einen entfernten Netzdrucker bedienen können.
> | Kann man "cups" so einstellen, dass er nicht die Module für den
> | Paralellport läd, aber trotzdem das "entfernte" Drucken
> | unterstützt? Wenn ja, wie?
>
> Ich würde an deiner Stelle das tun, was ich schon immer mache - und
> damit verschwindet eine Fülle von Problemen gans von alleine:
>
> 1. DEINSTALLIERE CUPS UND LPRNG. So ne Schei... wie diese
> Drucksysteme habe ich in meiner ganzen Linux-Zeit noch nicht erlebt.
> Immer wieder klemmt's irgendwo damit... (Vergiß nicht, daß an lprng
> und cups auch noch einige andere Pakete angehängt sind. --
> Deinstallation sollte mit YAST gebacht werden, damit die liebe SuSE
> auch weiß, daß das Klump gelöscht ist.
>
> 2. Nimm eine SuSE 7.3 und installiere von dieser manuell das Paket
> 'lprold'. Da die lieben SuSE Leute ja das was funzt offenbar nicht
> mehr beipacken, mußt du dir das lprold paket entweder aus dem
> Internet holen, oder eben von besagter Version 7.3.
>

Vielen Dank für Deinen Ratschlag. Das Problem an sich würde sich auch
durch das Paket "lprold" nicht lösen. Wie schon gesagt liegt es
definitv am Kernelmodul "lp", welches vom Kernelmodul "parport"
abhängt. (Ich habe das durch manuelles Nachladen im Single-User Modus
herausgefunden, in dem keine Dienste, d.h. auch keine Druckerdienste
wie "cups", geladen wurden.) Außerdem hatte ich es ja auch schon mit
dem Kernel 2.4.10-4GB aus SuSE 7.3 probiert, wo es mit CUPS
funktionierte.
Ich habe den Druckerdienst nur deshalb ausgeschaltet, da durch ihn ja
die entsprechenden Module geladen werden.

Die Kernel Entwickler bzw. die bei SuSE Zuständigen sollten mal das
Modul "lp" unter die Lupe nehmen.

Gruß,
Steffen

< Previous Next >
References